Home Forums
07 | 27 | 2016
JoomlaNook Forums
Welcome, Guest
Please Login or Register.    Lost Password?
HSConfig Component doesn't work after installation
(0 viewing) 
Configuration Component Problems.
Go to bottom
TOPIC: HSConfig Component doesn't work after installation
#174
Gonzo
Posts: 14
User Offline Click here to see the profile of this user
HSConfig Component doesn't work after installation 8 Years ago  
Hi,

I'm running an Joomla 1.5.1 installation and it may be due to the fact that I'm not upgraded to 1.5.3 that is causing the problem, but I'm hoping that is not the case as I'm very much afraid of breaking my working installation by upgrading.

My installation of both the plugin and the hsconfig component went fine. However, when I tried to create a new configuration using the New button in the Highslide JS Configuation Manager, the resulting Edit interface looks wrong to start. All of the "General Settings", "Captions", "Popup Content Settings", "Icons, Text and Tooltips", "HTML Extensions", and "Custom Overlay Settings" all indicate "No Parameters". From what I understand, this is WRONG. The editable sections for actual html look fine. This can all be seen in the attached image. Additionally, if I try to edit a new configuration and save it, I wind up at a blank page, and returning to the Highslide JS Configuration manager indicates no configuration was saved.

Finally, I'm installing this as I hope to be able to use the Imageflow for Joomla within a custom component of my own. I hope to be able to dynamically generate a list of images to provide the Imageflow module via the "Load images from" interface by dynamically creating the file that I set the module to use here. The problem is that I was hoping to add the custom overlay controls on the highslide popup as shown on your demo of Imageflow. To do that I needed to install Highslide JS, so I installed both the plugin and the component. My question here is since I want to use this from within my own component, I can't save a configuration to any of the articles listed. I was hoping that I could use the 'Always' for the 'Include Highslide Configuration' parameter here, but that does not appear as I have indicated.

Any help would be greatly appreciated.

Thanks in advance,

= Ed =
 
Logged Logged
 
Last Edit: 2008/07/07 18:00 By Gonzo. Reason: added image
  The administrator has disabled public write access.
#177
klowther
Admin
Posts: 3118
User Offline Click here to see the profile of this user
Gender: Male JoomlaNook Location: Fremont, NE USA Birthday: 07/23
Re:HSConfig Component doesn't work after installation 8 Years ago  
Hi Ed,

I'm afraid you need to be on at least 1.5.2. Some of the functions used by the config component were not available until 1.5.2.

From everything that you have described, I think upgrading would solve all the problems you are seeing.

Hope that helps.

- Ken
 
Logged Logged
 
Last Edit: 2008/07/07 22:31 By klowther.
  The administrator has disabled public write access.
#178
Gonzo
Posts: 14
User Offline Click here to see the profile of this user
Re:HSConfig Component doesn't work after installation 8 Years ago  
Thanks Ken. I was afraid of that. Maybe I won't need to use the Highslide plugin if Imageflow works well enough without it. I am really dubious about upgrading this site and then having to spend days getting all of the extensions functional again. Maybe I'll upgrade though. Always a hard decision.

= Ed =
 
Logged Logged
  The administrator has disabled public write access.
#179
klowther
Admin
Posts: 3118
User Offline Click here to see the profile of this user
Gender: Male JoomlaNook Location: Fremont, NE USA Birthday: 07/23
Re:HSConfig Component doesn't work after installation 8 Years ago  
Ed,

If all you want is the default configuration with a custom overlay, I can send you a copy of the generated css and js files. Thats all that the configuration component will produce anyway.

- Ken

PS: actually you can get them yourself. Here are the links:
www.joomlanook.com/hsconfig/js/highslide-article-44-settings.js

That gets the js config for the article on the frontpage.

www.joomlanook.com/hsconfig/css/highslide-article-44-styles.css

That gets the correspondng css config.
 
Logged Logged
 
Last Edit: 2008/07/08 00:11 By klowther.
  The administrator has disabled public write access.
Go to top